summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-08 20:11:39 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-09 10:20:01 +0100
commit49fb69d823cf3f62609841feee358384e719669f (patch)
treee13eda4a251bc4dd2a983c7f4d881d1bceba326c /Makefile.am
parent6e8997d86a0e6af3575f0f794380d4186fd446e4 (diff)
downloadautomake-49fb69d823cf3f62609841feee358384e719669f.tar.gz
docs: add rule to generate manuals for www.gnu.org
Less clerical work to do by hand. * Makefile.am (web-manuals): New rule. (clean_texinfo_clutter): New macro. * clean-web-manuals, clean-texinfo-clutter: New cleaning rules. (clean-local): Depend on them. * .gitignore: Update. * HACKING: Adjust instructions for generation of manuals. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c5fa7198..870c6a9a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1001,6 +1001,39 @@ fetch:
exit $$stat
.PHONY: fetch
+## --------------------------------------------------------------------- ##
+## Generate manuals in several formats, for upload on the GNU website. ##
+## --------------------------------------------------------------------- ##
+
+# The gendocs.sh script sadly leaves TeX and Texinfo auxiliary files
+# in the directory where it's invoked.
+clean_texinfo_clutter_cmd = \
+ cd doc && rm -f *.ac *.aux *.cm *.cp *.cps *.fn *.fns *.ky \
+ *.log *.op *.pg *.toc *.tp *.tr *.vr *.vrs
+
+clean-web-manuals:
+ $(AM_V_at)rm -rf doc/web-manuals
+clean-texinfo-clutter:
+ $(AM_V_at)$(clean_texinfo_clutter_cmd)
+clean-local: clean-web-manuals clean-texinfo-clutter
+.PHONY: clean-web-manuals clean-texinfo-clutter
+
+web-manuals:
+ $(AM_V_at)rm -rf doc/web-manuals
+ $(AM_V_GEN): \
+## The gendocs.sh script only works from the srcdir, sadly.
+ && cd $(srcdir)/doc \
+ && GENDOCS_TEMPLATE_DIR=../lib \
+ && export GENDOCS_TEMPLATE_DIR \
+## Try to respect silent rules.
+ && if $(AM_V_P); then :; else exec >/dev/null 2>&1; fi \
+## Finally generate the manual in several formats.
+ && $(SHELL) ../lib/gendocs.sh -o web-manuals \
+ --email $(PACKAGE_BUGREPORT) $(PACKAGE) '$(PACKAGE_NAME)'
+ $(AM_V_at)$(clean_texinfo_clutter_cmd)
+ $(AM_V_at)if $(AM_V_P); then ls -l doc/web-manuals; else :; fi
+.PHONY: web-manuals
+
EXTRA_DIST += lib/gendocs.sh lib/gendocs_template
## ------------------------------------------------ ##