summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-07 11:54:28 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-07 11:54:28 +0200
commitcbd1a6049adbbc21081104a1cb7c2b793652106a (patch)
tree106ea8740ae5df563e9f3751ae6d60768b6a4ba2 /Makefile.am
parentb3a5c6b4973209af0aa125f8916fff4070080ee9 (diff)
parent5197aba1d5e1895c28d66703b0b407c991f608fb (diff)
downloadautomake-cbd1a6049adbbc21081104a1cb7c2b793652106a.tar.gz
Merge branch 'maint'
* maint: cosmetics: rename t/ax/test-runner => t/ax/runtest fixup: another "make recheck" failure with BSD make test runner: work correctly in VPATH setups compat: automake should define $(mkdir_p), for backward compatibility coverage: test that AM_PROG_MKDIR_P and $(mkdir_p) still works tests init: don't automatically re-execute tests with a POSIX shell yacc tests: fix spurious failure with parallel make tests: ignore minor 'recheck' regression for BSD make tests: don't clutter the top-level dir with temporary test directories tests: avoid spurious failures when @MKDIR_P@ points to "install-sh -d" lisp: better support of VPATH builds news: fixlets and updates + Extra non-trivial edits: * NEWS: State that $(mkdir_p) is still provided as an alias to $(MKDIR_P), for (partial) backward-compatibility. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 44a6acae3..a396d8f3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -340,11 +340,6 @@ AM_TESTS_ENVIRONMENT = \
; do \
eval test x"\$${$$v}" = x || unset $$v; \
done;
-# The 'AM_TESTS_REEXEC=no' setting tells the tests not to needlessly
-# re-execute themselves with the shell detected at configure time, since
-# we are already running them under it explicitly in our setup (see e.g.
-# the definition of TEST_LOG_COMPILER above).
-AM_TESTS_ENVIRONMENT += AM_TESTS_REEXEC=no; export AM_TESTS_REEXEC;
# We want warning messages and explanations for skipped tests to go to
# the console if possible, so set up 'stderr_fileno_' properly.
AM_TESTS_FD_REDIRECT = 9>&2
@@ -405,6 +400,17 @@ defs-static: defs-static.in Makefile
EXTRA_DIST += defs-static.in
CLEANFILES += defs-static
+t/ax/runtest: t/ax/runtest.in Makefile
+ $(AM_V_at)rm -f $@ $@-t
+ $(AM_V_GEN)in=t/ax/runtest.in \
+ && $(MKDIR_P) t/ax \
+ && $(do_subst) <$(srcdir)/t/ax/runtest.in >$@-t \
+ && chmod a+x $@-t
+ $(generated_file_finalize)
+EXTRA_DIST += t/ax/runtest.in
+CLEANFILES += t/ax/runtest
+noinst_SCRIPTS = t/ax/runtest
+
# If two test scripts have the same basename, they will end up sharing
# the same log file, leading to all sort of undefined and undesired
# behaviours.