summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-07-07 12:08:05 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-07-07 12:28:40 +0200
commitea93d8d05cf61d11a557e21b47f4736e337f6b1a (patch)
tree34fb82146603b91a34ef0b28bf76c1e008fcefd5 /Makefile.am
parent5197aba1d5e1895c28d66703b0b407c991f608fb (diff)
downloadautomake-ea93d8d05cf61d11a557e21b47f4736e337f6b1a.tar.gz
tests: move 'runtest' into the top-level directory
Move our wrapper script 'runtest' (meant to allow the execution of Automake test cases from the command line) from the 't/ax/' directory to the top-level one. This makes the script easier to find and to invoke. Much more importantly, our DejaGNU-checking test cases won't try anymore to use that script instead of the 'runtest' program provided by DejaGNU (that happened because '$(srcdir)/t/ax/' is automatically added early to the $PATH variable in our test cases), which was causing spurious SKIPs. * t/ax/runtest.in: Move ... * runtest.in: ... here. * Makefile.am, t/README, .gitignore: Adjust. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 9ef2f48c4..276448158 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -400,16 +400,16 @@ defs-static: defs-static.in Makefile
EXTRA_DIST += defs-static.in
CLEANFILES += defs-static
-t/ax/runtest: t/ax/runtest.in Makefile
+runtest: runtest.in Makefile
$(AM_V_at)rm -f $@ $@-t
- $(AM_V_GEN)in=t/ax/runtest.in \
+ $(AM_V_GEN)in=runtest.in \
&& $(MKDIR_P) t/ax \
- && $(do_subst) <$(srcdir)/t/ax/runtest.in >$@-t \
+ && $(do_subst) <$(srcdir)/runtest.in >$@-t \
&& chmod a+x $@-t
$(generated_file_finalize)
-EXTRA_DIST += t/ax/runtest.in
-CLEANFILES += t/ax/runtest
-noinst_SCRIPTS = t/ax/runtest
+EXTRA_DIST += runtest.in
+CLEANFILES += runtest
+noinst_SCRIPTS = runtest
# If two test scripts have the same basename, they will end up sharing
# the same log file, leading to all sort of undefined and undesired