summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-13 12:09:32 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-13 20:18:10 +0100
commitf22f41c10e03a59b8db25d536be209a48cbd7f61 (patch)
treee25509b1bfc932eb38a5ecfa3cb1b983bc3b2351 /Makefile.am
parentaf431631cc9db8b5426308d44fc2773afca5816c (diff)
downloadautomake-f22f41c10e03a59b8db25d536be209a48cbd7f61.tar.gz
maint: factor out the name of the dir where web manuals are generated
Just a minor refactoring to reduce duplication; no semantic change is intended. * Makefile.am (web_manual_dir): New. (web-manual, web-manual-update, clean-web-manual): Use it. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 895afa8be..aa899b3a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -997,6 +997,8 @@ fetch:
## Generate and upload manuals in several formats, for the GNU website. ##
## ---------------------------------------------------------------------- ##
+web_manual_dir = doc/web-manual
+
RSYNC = rsync
CVS = cvs
CVSU = cvsu
@@ -1004,7 +1006,7 @@ CVS_USER = $${USER}
WEBCVS_ROOT = cvs.savannah.gnu.org:/web
web-manual:
- $(AM_V_at)rm -rf doc/web-manuals
+ $(AM_V_at)rm -rf $(web_manual_dir)
$(AM_V_GEN)tmp=$@.dir \
&& rm -rf $$tmp \
&& mkdir $$tmp \
@@ -1020,10 +1022,10 @@ web-manual:
-I '$(abs_srcdir)/doc' --email $(PACKAGE_BUGREPORT) \
$(PACKAGE) '$(PACKAGE_NAME)'
$(AM_V_at)tmp=$@.dir \
- && mkdir doc/web-manuals \
- && mv -f $$tmp/manual/* doc/web-manuals \
+ && mkdir $(web_manual_dir) \
+ && mv -f $$tmp/manual/* $(web_manual_dir) \
&& rm -rf $$tmp \
- && { ! $(AM_V_P) || ls -l doc/web-manuals; }
+ && { ! $(AM_V_P) || ls -l $(web_manual_dir); }
.PHONY: web-manual
web-manual-update:
@@ -1034,7 +1036,7 @@ web-manual-update:
*) echo "Cannot upload manuals from a \"$$release_type\"" >&2; \
exit 1;; \
esac
- $(AM_V_at)test -f doc/web-manuals/$(PACKAGE).html || { \
+ $(AM_V_at)test -f $(web_manual_dir)/$(PACKAGE).html || { \
echo 'You have to run "$(MAKE) web-manuals" before' \
'invoking "$(MAKE) $@"' >&2; \
exit 1; \
@@ -1048,7 +1050,7 @@ web-manual-update:
&& $(CVS) -z3 -d :ext:$(CVS_USER)@$(WEBCVS_ROOT)/$(PACKAGE) \
co $(PACKAGE) \
&& cd .. \
- && $(RSYNC) -avP doc/web-manuals/ $$tmp/$(PACKAGE)/manual \
+ && $(RSYNC) -avP $(web_manual_dir)/ $$tmp/$(PACKAGE)/manual \
&& ( \
cd $$tmp/$(PACKAGE)/manual \
&& new_files=`$(CVSU) --types='?'` \
@@ -1060,7 +1062,7 @@ web-manual-update:
.PHONY: web-manual-update
clean-web-manual:
- $(AM_V_at)rm -rf doc/web-manuals
+ $(AM_V_at)rm -rf $(web_manual_dir)
.PHONY: clean-web-manual
clean-local: clean-web-manual