summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriel F. T. Gomes <gabriel@inconstante.net.br>2020-01-24 19:24:09 -0300
committerGabriel F. T. Gomes <gabriel@inconstante.net.br>2020-01-24 19:24:09 -0300
commit019f3cc463db63abc6460f97deb488deec43840b (patch)
tree08cd5387d6c8af6f688d6468c7e2ae9f25c449be /Makefile.am
parent5732da2af736c40cf693354485446ab4867ecb4d (diff)
downloadbash-completion-019f3cc463db63abc6460f97deb488deec43840b.tar.gz
New upstream version 2.10upstream/2.10
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f441185..26f3c7c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,7 @@ SUBDIRS = completions doc helpers test
pkgdata_DATA = bash_completion
# Empty, but here just to get the compat dir created with install
+compatdir = $(sysconfdir)/bash_completion.d
compat_DATA =
profiledir = $(sysconfdir)/profile.d
@@ -18,8 +19,9 @@ cmakeconfig_DATA = bash-completion-config.cmake \
%: %.in Makefile
$(SED) \
-e 's|@prefix[@]|$(prefix)|' \
- -e 's|@compatdir[@]|$(compatdir)|' \
- -e 's|@pkgdatadir[@]|$(pkgdatadir)|' \
+ -e 's|@datadir[@]|$(datadir)|' \
+ -e 's|@sysconfdir[@]|$(sysconfdir)|' \
+ -e 's|@PACKAGE[@]|$(PACKAGE)|' \
-e 's|@VERSION[@]|$(VERSION)|' \
<$(srcdir)/$@.in >$@
@@ -29,11 +31,11 @@ CLEANFILES = bash_completion.sh bash-completion.pc \
EXTRA_DIST = CHANGES $(pkgdata_DATA) bash_completion.sh.in .dir-locals.el \
.editorconfig README.md CONTRIBUTING.md pyproject.toml .perltidyrc \
.shellcheckrc bash-completion.pc.in bash-completion-config.cmake.in \
- bash-completion-config-version.cmake.in
+ bash-completion-config-version.cmake.in setup-symlinks.sh
install-data-hook:
tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \
$(SED) -e 's|-/etc/bash_completion\.d|-$(compatdir)|' \
- $(DESTDIR)$(pkgdatadir)/bash_completion >$$tmpfile && \
- cat $$tmpfile >$(DESTDIR)$(pkgdatadir)/bash_completion && \
+ $(DESTDIR)$(datadir)/$(PACKAGE)/bash_completion >$$tmpfile && \
+ cat $$tmpfile >$(DESTDIR)$(datadir)/$(PACKAGE)/bash_completion && \
rm $$tmpfile