summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Paleino <dapal@debian.org>2012-01-08 00:19:18 +0100
committerDavid Paleino <dapal@debian.org>2012-01-08 00:19:18 +0100
commitc3d398fcc6e400be546c28eb1fc25abfa5816eac (patch)
tree3266a00f1037eb5522f1f8bf1a73e443ab2c26c4 /Makefile.am
parent2c8171c38d87ddef31c92a76547d3fdf773a1337 (diff)
downloadbash-completion-c3d398fcc6e400be546c28eb1fc25abfa5816eac.tar.gz
Imported Upstream version 1.99upstream/1.99
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3441b630..dbbba0c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,10 @@
-SUBDIRS = completions helpers test
+SUBDIRS = completions doc helpers test
pkgdata_DATA = bash_completion
+# Empty, but here just to get the compat dir created with install
+compat_DATA =
+
profiledir = $(sysconfdir)/profile.d
profile_DATA = bash_completion.sh
@@ -18,6 +21,7 @@ EXTRA_DIST = CHANGES $(sysconf_DATA) $(pkgdata_DATA) bash_completion.sh.in \
install-data-hook:
tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \
- sed -e 's|=/etc/bash_completion\.d|=$(sysconfdir)/bash_completion.d|' \
+ sed -e 's|=/etc/bash_completion\.d|=$(compatdir)|' \
$(DESTDIR)$(pkgdatadir)/bash_completion > $$tmpfile && \
- mv $$tmpfile $(DESTDIR)$(pkgdatadir)/bash_completion
+ cat $$tmpfile > $(DESTDIR)$(pkgdatadir)/bash_completion && \
+ rm $$tmpfile