summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3441b630..dbbba0c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,10 @@
-SUBDIRS = completions helpers test
+SUBDIRS = completions doc helpers test
pkgdata_DATA = bash_completion
+# Empty, but here just to get the compat dir created with install
+compat_DATA =
+
profiledir = $(sysconfdir)/profile.d
profile_DATA = bash_completion.sh
@@ -18,6 +21,7 @@ EXTRA_DIST = CHANGES $(sysconf_DATA) $(pkgdata_DATA) bash_completion.sh.in \
install-data-hook:
tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \
- sed -e 's|=/etc/bash_completion\.d|=$(sysconfdir)/bash_completion.d|' \
+ sed -e 's|=/etc/bash_completion\.d|=$(compatdir)|' \
$(DESTDIR)$(pkgdatadir)/bash_completion > $$tmpfile && \
- mv $$tmpfile $(DESTDIR)$(pkgdatadir)/bash_completion
+ cat $$tmpfile > $(DESTDIR)$(pkgdatadir)/bash_completion && \
+ rm $$tmpfile