summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-11-25 23:54:16 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-11-25 23:54:16 +0300
commit8199a20978e5a3f637ca61975d6e81632b0113cb (patch)
treec0f220212f4f28c19b3c5aa84f824d5e51a127c9 /CMakeLists.txt
parent07d08b8151401ef87792ff1f130b2fad738f306f (diff)
downloadbdwgc-8199a20978e5a3f637ca61975d6e81632b0113cb.tar.gz
Remove doc.am and move gc.man to base folder
(refactoring) This is to eliminate non-dist-doc files in doc folder. * CMakeLists.txt [enable_docs] (doc/gc.man): Rename to gc.man. * Makefile.am [ENABLE_DOCS] (dist_man3_MANS): Likewise. * Makefile.direct (BSD-pkg-install): Likewise. * Makefile.am: Do not include doc/doc.am. * Makefile.am [ENABLE_DOCS] (dist_doc_DATA, dist_man3_MANS): Copy assignment from doc.am. * doc/doc.am: Remove. * doc/gc.man: Rename to gc.man.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 495a1c7b..82f3ec1d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -730,8 +730,7 @@ if (enable_docs)
PATTERN "README.*"
PATTERN "*.md")
- install(FILES doc/gc.man DESTINATION "${CMAKE_INSTALL_MANDIR}/man3"
- RENAME gc.3)
+ install(FILES gc.man DESTINATION "${CMAKE_INSTALL_MANDIR}/man3" RENAME gc.3)
endif(enable_docs)
# CMake config/targets files.