summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2021-11-23 10:36:56 +0300
committerIvan Maidanski <ivmai@mail.ru>2021-11-23 17:37:52 +0300
commiteb20384b1985eaf1711ae07d8558a58e9cfbe28e (patch)
tree64c54a49f71b1510fb715a5d6b303b038b07df95 /CMakeLists.txt
parentdf69c3f4ceb6f80b2dfc59070f55ada1264cf708 (diff)
downloadbdwgc-eb20384b1985eaf1711ae07d8558a58e9cfbe28e.tar.gz
Rename README.QUICK to LICENSE and install it by default
README.QUICK contains the package copyright and licensing terms, it is more natural to name the file as LICENSE. * CMakeLists.txt [enable_docs] (install): Add LICENSE for $CMAKE_INSTALL_DOCDIR; remove note that README.QUICK is not installed. * README.QUICK: Rename to LICENSE. * Makefile.am (EXTRA_DIST): Do not add README.QUICK. * README.md (Copyright & Warranty, Contributors): Rename README.QUICK to LICENSE. * doc/README.DGUX386: Refer to README.md instead of README.QUICK. * doc/doc.am [ENABLE_DOCS] (dist_doc_DATA): Add LICENSE.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b827f74..f975e9e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -716,8 +716,7 @@ if (build_tests)
endif(build_tests)
if (enable_docs)
- # Note: documentation which is not installed: README.QUICK
- install(FILES AUTHORS README.md
+ install(FILES AUTHORS LICENSE README.md
DESTINATION "${CMAKE_INSTALL_DOCDIR}")
install(DIRECTORY doc/ DESTINATION "${CMAKE_INSTALL_DOCDIR}"
FILES_MATCHING