summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@google.com>2012-10-24 02:26:39 +0000
committerCary Coutant <ccoutant@google.com>2012-10-24 02:26:39 +0000
commit34ce70fa99d7bc72b04be302800db348e99c33c0 (patch)
treeaf7a192d5ed00dbbf58e933ab8ccdf1e457fbb52 /gold/Makefile.am
parent387c7a3fac1150418a8fa2f3fca672904b9a105b (diff)
downloadbinutils-redhat-34ce70fa99d7bc72b04be302800db348e99c33c0.tar.gz
gold/
* dwp.h: New header file. * dwp.cc: New source file. * gold.h: Move shared declarations to system.h. * system.h: New header file. * Makefile.am: Add dwp. * Makefile.in: Regenerate.
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index aa8caca658..f82d4e9e1a 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -34,6 +34,8 @@ AM_YFLAGS = -d
am__skiplex =
am__skipyacc =
+bin_PROGRAMS = dwp
+
noinst_PROGRAMS = ld-new incremental-dump
noinst_LIBRARIES = libgold.a
@@ -172,6 +174,12 @@ incremental_dump_DEPENDENCIES = $(TARGETOBJS) libgold.a $(LIBIBERTY) \
incremental_dump_LDADD = $(TARGETOBJS) libgold.a $(LIBIBERTY) $(LIBINTL) \
$(THREADSLIB) $(LIBDL)
+dwp_SOURCES = dwp.cc
+dwp_DEPENDENCIES = libgold.a $(LIBIBERTY) $(LIBINTL_DEP)
+dwp_LDADD = libgold.a $(LIBIBERTY) $(GOLD_LDADD) $(LIBINTL) $(THREADSLIB) \
+ $(LIBDL)
+dwp_LDFLAGS = $(GOLD_LDFLAGS)
+
# Use an explicit dependency for the bison generated header file.
expression.$(OBJEXT): yyscript.h
script-sections.$(OBJEXT): yyscript.h