summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index aa8caca658..f82d4e9e1a 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -34,6 +34,8 @@ AM_YFLAGS = -d
am__skiplex =
am__skipyacc =
+bin_PROGRAMS = dwp
+
noinst_PROGRAMS = ld-new incremental-dump
noinst_LIBRARIES = libgold.a
@@ -172,6 +174,12 @@ incremental_dump_DEPENDENCIES = $(TARGETOBJS) libgold.a $(LIBIBERTY) \
incremental_dump_LDADD = $(TARGETOBJS) libgold.a $(LIBIBERTY) $(LIBINTL) \
$(THREADSLIB) $(LIBDL)
+dwp_SOURCES = dwp.cc
+dwp_DEPENDENCIES = libgold.a $(LIBIBERTY) $(LIBINTL_DEP)
+dwp_LDADD = libgold.a $(LIBIBERTY) $(GOLD_LDADD) $(LIBINTL) $(THREADSLIB) \
+ $(LIBDL)
+dwp_LDFLAGS = $(GOLD_LDFLAGS)
+
# Use an explicit dependency for the bison generated header file.
expression.$(OBJEXT): yyscript.h
script-sections.$(OBJEXT): yyscript.h