summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2010-02-06 20:14:01 +0000
committerIan Lance Taylor <ian@airs.com>2010-02-06 20:14:01 +0000
commit1a44fa0da176c0e7ee27bab5744976e263ee345b (patch)
treeeb8a453a5eee054fd088314b921b23fd8a9734d2 /gold/configure.ac
parentb7a42d51bacadb185f4422ac6d99361519409de8 (diff)
downloadbinutils-redhat-1a44fa0da176c0e7ee27bab5744976e263ee345b.tar.gz
* configure.ac: Rewrite targetobjs duplicate removal code to use
only shell constructs. * configure: Rebuild.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 4bf223cb51..f184d4b29d 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -163,7 +163,14 @@ for targ in $target $canon_targets; do
done
# Remove any duplicates.
-targetobjs=`echo $targetobjs | tr ' ' '\n' | sort | uniq | tr '\n' ' '`
+to=""
+for t in $targetobjs; do
+ case " $to " in
+ *" $t "*) ;;
+ *) to="$to $t" ;;
+ esac
+done
+targetobjs=$to
if test -n "$targ_32_little"; then
AC_DEFINE(HAVE_TARGET_32_LITTLE, 1,