summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 4bf223cb51..f184d4b29d 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -163,7 +163,14 @@ for targ in $target $canon_targets; do
done
# Remove any duplicates.
-targetobjs=`echo $targetobjs | tr ' ' '\n' | sort | uniq | tr '\n' ' '`
+to=""
+for t in $targetobjs; do
+ case " $to " in
+ *" $t "*) ;;
+ *) to="$to $t" ;;
+ esac
+done
+targetobjs=$to
if test -n "$targ_32_little"; then
AC_DEFINE(HAVE_TARGET_32_LITTLE, 1,