summaryrefslogtreecommitdiff
path: root/ld/configure.in
diff options
context:
space:
mode:
authorJim Wilson <wilson@tuliptree.org>2005-06-09 18:39:34 +0000
committerJim Wilson <wilson@tuliptree.org>2005-06-09 18:39:34 +0000
commit940c1aa51398c7414144fc66cd30b0149cbad558 (patch)
treef414d5a5f34cd44ebfb06def8eb64a1053943da4 /ld/configure.in
parent57557d8344acc7ebbb9eec964431b027cec03d18 (diff)
downloadbinutils-redhat-940c1aa51398c7414144fc66cd30b0149cbad558.tar.gz
configure clean up patch from Steve Ellcey.
* configure.in (AM_BINUTILS_WARNINGS): Add. (BFD_NEED_DECLARATION) Replace with AC_CHECK_DECLS. * config.in: Regenerate. * configure: Regenerate. * sysdep.h (NEED_DECLARATION_*): Replace with HAVE_DECL_* * ldmain.c: Ditto.
Diffstat (limited to 'ld/configure.in')
-rw-r--r--ld/configure.in49
1 files changed, 2 insertions, 47 deletions
diff --git a/ld/configure.in b/ld/configure.in
index ec791fc8c9..22ff444696 100644
--- a/ld/configure.in
+++ b/ld/configure.in
@@ -66,48 +66,7 @@ AC_SUBST(use_sysroot)
AC_SUBST(TARGET_SYSTEM_ROOT)
AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
-dnl FIXME: The following is bfd/warning.m4 contents expanded
-dnl When converting to current autotools, please replace with
-dnl AM_BINUTILS_WARNINGS
-WARN_CFLAGS="-W -Wall -Wstrict-prototypes -Wmissing-prototypes"
-
-AC_ARG_ENABLE(werror,
- [ --enable-werror treat compile warnings as errors],
- [case "${enableval}" in
- yes | y) ERROR_ON_WARNING="yes" ;;
- no | n) ERROR_ON_WARNING="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-werror) ;;
- esac])
-
-# Enable -Werror by default when using gcc
-if test "${GCC}" = yes -a -z "${ERROR_ON_WARNING}" ; then
- ERROR_ON_WARNING=yes
-fi
-
-NO_WERROR=
-if test "${ERROR_ON_WARNING}" = yes ; then
- WARN_CFLAGS="$WARN_CFLAGS -Werror"
- NO_WERROR="-Wno-error"
-fi
-
-AC_ARG_ENABLE(build-warnings,
-[ --enable-build-warnings Enable build-time compiler warnings],
-[case "${enableval}" in
- yes) ;;
- no) WARN_CFLAGS="-w";;
- ,*) t=`echo "${enableval}" | sed -e "s/,/ /g"`
- WARN_CFLAGS="${WARN_CFLAGS} ${t}";;
- *,) t=`echo "${enableval}" | sed -e "s/,/ /g"`
- WARN_CFLAGS="${t} ${WARN_CFLAGS}";;
- *) WARN_CFLAGS=`echo "${enableval}" | sed -e "s/,/ /g"`;;
-esac])
-
-if test x"$silent" != x"yes" && test x"$WARN_CFLAGS" != x""; then
- echo "Setting warning flags = $WARN_CFLAGS" 6>&1
-fi
-
-AC_SUBST(WARN_CFLAGS)
-AC_SUBST(NO_WERROR)
+AM_BINUTILS_WARNINGS
AM_CONFIG_HEADER(config.h:config.in)
@@ -156,11 +115,7 @@ fi
BFD_BINARY_FOPEN
-BFD_NEED_DECLARATION(strstr)
-BFD_NEED_DECLARATION(free)
-BFD_NEED_DECLARATION(sbrk)
-BFD_NEED_DECLARATION(getenv)
-BFD_NEED_DECLARATION(environ)
+AC_CHECK_DECLS([strstr, free, sbrk, getenv, environ])
# When converting linker scripts into strings for use in emulation
# files, use astring.sed if the compiler supports ANSI string