summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-11 16:25:39 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-17 14:15:42 +0200
commit1d76b2ee1f098f144c006e83e9de04f91b1ec9b3 (patch)
treea46df2b6854ec1c8066c44c308ff6b586017cc1f /configure.ac
parent26e38bbcef1b7ab53290ed3a113a4328700e7e80 (diff)
downloadbluez-1d76b2ee1f098f144c006e83e9de04f91b1ec9b3.tar.gz
build: Add option to enable SAP profile
This adds --enable-sap option dedicated to enabled sap plugin so it is no longer enabled with --enable-experimental leaving it to just enable experimental tools.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1aa20a8c..ce57b63f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,6 +144,10 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-nfc],
[enable NFC paring]), [enable_nfc=${enableval}])
AM_CONDITIONAL(NFC, test "${enable_nfc}" = "yes")
+AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-sap],
+ [enable SAP profile]), [enable_sap=${enableval}])
+AM_CONDITIONAL(SAP, test "${enable_sap}" = "yes")
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")