summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-11 15:40:54 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-17 14:15:42 +0200
commit1e9ab1dab72d8d6cb29867dde9275306d2157091 (patch)
tree8cf5f7c208a58c892fa85d6ecf8f6c3a6a5613c5 /configure.ac
parent1d76b2ee1f098f144c006e83e9de04f91b1ec9b3 (diff)
downloadbluez-1e9ab1dab72d8d6cb29867dde9275306d2157091.tar.gz
build: Add option to disable A2DP profile
This adds --disable-a2dp option to configure which make A2DP plugin to not be build thus reducing the build time and binary size of bluetoothd in systems where A2DP is not supported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ce57b63f9..6761e29f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,6 +148,10 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-sap],
[enable SAP profile]), [enable_sap=${enableval}])
AM_CONDITIONAL(SAP, test "${enable_sap}" = "yes")
+AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-a2dp],
+ [disable A2DP profile]), [enable_a2dp=${enableval}])
+AM_CONDITIONAL(A2DP, test "${enable_a2dp}" != "no")
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")