summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-11 16:02:06 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-17 14:15:42 +0200
commit435b3be70eb796703a8da83096bf9db583854cfb (patch)
tree83058542983470d3763169d7ce30542fff66ecdc /configure.ac
parenta9643f63ee9304884ec3188bfbb26c69f467f529 (diff)
downloadbluez-435b3be70eb796703a8da83096bf9db583854cfb.tar.gz
build: Add option to disable HID profile
This adds --disable-hid option to configure which make input plugin to not be build thus reducing the build time and binary size of bluetoothd in systems where HID profile is not supported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63a5dfbe4..e63579ecf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,10 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-network],
[disable network profiles]), [enable_network=${enableval}])
AM_CONDITIONAL(NETWORK, test "${enable_network}" != "no")
+AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-hid],
+ [disable HID profile]), [enable_hid=${enableval}])
+AM_CONDITIONAL(HID, test "${enable_hid}" != "no")
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")