summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-11 15:52:55 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-17 14:15:42 +0200
commita9643f63ee9304884ec3188bfbb26c69f467f529 (patch)
tree76dc6e7636703595a4880da8ccc29245e2983f02 /configure.ac
parentb5bab5ea0e3cef4444d8d26d4f7e69789d210b70 (diff)
downloadbluez-a9643f63ee9304884ec3188bfbb26c69f467f529.tar.gz
build: Add option to disable network profiles
This adds --disable-network option to configure which make network plugin to not be build thus reducing the build time and binary size of bluetoothd in systems where those profiles are not supported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 99fbeb83e..63a5dfbe4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,10 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-avrcp],
[disable AVRCP profile]), [enable_avrcp=${enableval}])
AM_CONDITIONAL(AVRCP, test "${enable_avrcp}" != "no")
+AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-network],
+ [disable network profiles]), [enable_network=${enableval}])
+AM_CONDITIONAL(NETWORK, test "${enable_network}" != "no")
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")