summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-11 15:47:25 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2016-11-17 14:15:42 +0200
commitb5bab5ea0e3cef4444d8d26d4f7e69789d210b70 (patch)
tree1fe77d33616ae3cfcc9fc4e74e3e308edf259471 /configure.ac
parent1e9ab1dab72d8d6cb29867dde9275306d2157091 (diff)
downloadbluez-b5bab5ea0e3cef4444d8d26d4f7e69789d210b70.tar.gz
build: Add option to disable AVRCP profile
This adds --disable-avrcp option to configure which make AVRCP plugin to not be build thus reducing the build time and binary size of bluetoothd in systems where AVRCP is not supported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6761e29f3..99fbeb83e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,10 @@ AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-a2dp],
[disable A2DP profile]), [enable_a2dp=${enableval}])
AM_CONDITIONAL(A2DP, test "${enable_a2dp}" != "no")
+AC_ARG_ENABLE(test, AC_HELP_STRING([--disable-avrcp],
+ [disable AVRCP profile]), [enable_avrcp=${enableval}])
+AM_CONDITIONAL(AVRCP, test "${enable_avrcp}" != "no")
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable Bluetooth tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")