summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTedd Ho-Jeong An <tedd.an@intel.com>2021-05-11 13:08:43 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-05-11 15:15:25 -0700
commitd8397fe21cdcffd347b11328ba4b3b11a79b6299 (patch)
tree212fd6dcdc2e8568cd60c50f0efe4eee467b591f /configure.ac
parentdb40060a8d59cd7d2ff940fb0f7e1d6234c88171 (diff)
downloadbluez-d8397fe21cdcffd347b11328ba4b3b11a79b6299.tar.gz
config: Change the config option for manpages
The current config option for manpages provided by the configure.ac alwasys enables the manpages whether 'enable-manpages' option is specified or not. To clarify the expected behavior, this patch changes the manpages option to 'disable-manpages' so the manpages are alwasy enabled unless the '--disable-manpages' option is specified.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2b044f8e5..5157da1b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,8 +323,8 @@ AC_ARG_ENABLE(datafiles, AC_HELP_STRING([--disable-datafiles],
[enable_datafiles=${enableval}])
AM_CONDITIONAL(DATAFILES, test "${enable_datafiles}" != "no")
-AC_ARG_ENABLE(manpages, AC_HELP_STRING([--enable-manpages],
- [enable building of manual pages]),
+AC_ARG_ENABLE(manpages, AC_HELP_STRING([--disable-manpages],
+ [disable building of manual pages]),
[enable_manpages=${enableval}])
if (test "${enable_manpages}" != "no"); then
AC_CHECK_PROGS(RST2MAN, [rst2man rst2man.py], "no")
@@ -332,8 +332,8 @@ if (test "${enable_manpages}" != "no"); then
AC_MSG_ERROR([rst2man is required])
fi
fi
-AM_CONDITIONAL(MANPAGES, test "${enable_manpages}" = "yes")
-AM_CONDITIONAL(RUN_RST2MAN, test "${enable_manpages}" = "yes" && test "${RST2MAN}" != "no")
+AM_CONDITIONAL(MANPAGES, test "${enable_manpages}" != "no")
+AM_CONDITIONAL(RUN_RST2MAN, test "${enable_manpages}" != "no" && test "${RST2MAN}" != "no")
AC_ARG_ENABLE(testing, AC_HELP_STRING([--enable-testing],
[enable testing tools]),