summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorUli Schlachter <psychon@znc.in>2021-05-02 21:25:48 +0200
committerUli Schlachter <psychon@znc.in>2021-05-02 21:25:48 +0200
commit45cca0c984c17e98964beb63410627298d1f6a01 (patch)
treea810c462dc30d8907593ea1e42de7071995e7de1 /meson.build
parent4f61b765c9f657fd755194afe576e56f945af4b6 (diff)
downloadcairo-45cca0c984c17e98964beb63410627298d1f6a01.tar.gz
meson: Move CAIRO_HAS_INTERPRETER to config.h
This is what autoconf does and hopefully that means this is the correct thing to do. Signed-off-by: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 06df7f9c1..9901bdf29 100644
--- a/meson.build
+++ b/meson.build
@@ -686,7 +686,7 @@ if zlib_dep.found()
endif
if zlib_dep.found()
- feature_conf.set('CAIRO_HAS_INTERPRETER', 1)
+ conf.set('CAIRO_HAS_INTERPRETER', 1)
endif
# TODO: add xml option and disable by default
@@ -970,6 +970,6 @@ if meson.version().version_compare('>= 0.53')
summary({
'cairo-trace:': conf.get('CAIRO_HAS_TRACE', 0) == 1,
- 'cairo-script-interpreter': feature_conf.get('CAIRO_HAS_INTERPRETER', 0) == 1,
+ 'cairo-script-interpreter': conf.get('CAIRO_HAS_INTERPRETER', 0) == 1,
}, section: 'Features and Utilities', bool_yn: true)
endif