summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-18 00:02:45 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-02-25 02:09:58 +0000
commit9b9028c160a404771fe0caeecda8f4248997a808 (patch)
tree5322cc3ca71ac15fed4b5dfa684352a7c0edcc7e /meson.build
parentfc3437128d7b45ba34007abbbeea2a81b1b126fb (diff)
downloadcairo-9b9028c160a404771fe0caeecda8f4248997a808.tar.gz
Drop cairo-vg surface
OpenVG is a failed experiment from 10 years ago, and nobody has been using the cairo-vg surface in pretty much the same amount of time.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 0 insertions, 17 deletions
diff --git a/meson.build b/meson.build
index ab2f96f99..75a7bdfa7 100644
--- a/meson.build
+++ b/meson.build
@@ -576,22 +576,6 @@ if feature_conf.get('CAIRO_HAS_GL_SURFACE', 0) == 0 and feature_conf.get('CAIRO_
endif
endif
-# Untested
-openvg_dep = cc.find_library('OpenVG', has_headers: 'VG/openvg.h', required: get_option('openvg'))
-if openvg_dep.found()
- deps += [openvg_dep]
-
- need_egl_functions = true
- need_glx_functions = true
-
- feature_conf.set('CAIRO_HAS_VG_SURFACE', 1)
- built_features += [{
- 'name': 'cairo-vg',
- 'description': 'OpenVG surface backend',
- 'deps': [openvg_dep],
- }]
-endif
-
if need_egl_functions
# FIXME: automagic
egl_extra_deps = []
@@ -950,7 +934,6 @@ summary({
'OpenGL': feature_conf.get('CAIRO_HAS_GL_SURFACE', 0) == 1,
'OpenGL ES 2.0': feature_conf.get('CAIRO_HAS_GLESV2_SURFACE', 0) == 1,
'OpenGL ES 3.0': feature_conf.get('CAIRO_HAS_GLESV3_SURFACE', 0) == 1,
- 'OpenVG': feature_conf.get('CAIRO_HAS_VG_SURFACE', 0) == 1,
}, section: 'Surface Backends', bool_yn: true)
summary({