summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-04-17 23:59:28 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-02-25 02:03:35 +0000
commitfc3437128d7b45ba34007abbbeea2a81b1b126fb (patch)
treec1a69a0270f1e329aa8a7f33793c5ebd538ef95a /meson.build
parent803afe6edda17b97e3d12a20585e565a2d2a79a2 (diff)
downloadcairo-fc3437128d7b45ba34007abbbeea2a81b1b126fb.tar.gz
Remove cairo-directfb
Nobody cares about DirectFB any more, not even the people that registered and maintained the DirectFB domain.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 0 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 3a776f6e9..ab2f96f99 100644
--- a/meson.build
+++ b/meson.build
@@ -577,19 +577,6 @@ if feature_conf.get('CAIRO_HAS_GL_SURFACE', 0) == 0 and feature_conf.get('CAIRO_
endif
# Untested
-directfb_dep = dependency('directfb', required: get_option('directfb'))
-if directfb_dep.found()
- deps += [directfb_dep]
-
- feature_conf.set('CAIRO_HAS_DIRECTFB_SURFACE', 1)
- built_features += [{
- 'name': 'cairo-directfb',
- 'description': 'directfb surface backend',
- 'deps': [directfb_dep],
- }]
-endif
-
-# Untested
openvg_dep = cc.find_library('OpenVG', has_headers: 'VG/openvg.h', required: get_option('openvg'))
if openvg_dep.found()
deps += [openvg_dep]
@@ -963,7 +950,6 @@ summary({
'OpenGL': feature_conf.get('CAIRO_HAS_GL_SURFACE', 0) == 1,
'OpenGL ES 2.0': feature_conf.get('CAIRO_HAS_GLESV2_SURFACE', 0) == 1,
'OpenGL ES 3.0': feature_conf.get('CAIRO_HAS_GLESV3_SURFACE', 0) == 1,
- 'DirectFB': feature_conf.get('CAIRO_HAS_DIRECTFB_SURFACE', 0) == 1,
'OpenVG': feature_conf.get('CAIRO_HAS_VG_SURFACE', 0) == 1,
}, section: 'Surface Backends', bool_yn: true)