summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2021-05-03 18:44:53 +0200
committerGitHub <noreply@github.com>2021-05-03 18:44:53 +0200
commitb96ca763c453a602b5516b4b9ca5e2829528e318 (patch)
tree670b9453be35a99841dfa36f7ce2425f4c331b8a /CMakeLists.txt
parent53b54bd6fba900842b1bd0939fb9f9616807515d (diff)
downloadccache-b96ca763c453a602b5516b4b9ca5e2829528e318.tar.gz
CMake: make build of documentation optional (#842)
So we don't need to support corner cases as for example one fixed in commit f6202db308e3 ("doc/MANUAL.adoc: Don't use non-ASCII quotes (#761)") when the documentation is actually not needed at all as ccache is used as a build tool only. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0825f2af..e186e812 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,7 +133,10 @@ target_link_libraries(ccache PRIVATE standard_settings standard_warnings ccache_
#
# Documentation
#
-add_subdirectory(doc)
+option(ENABLE_DOCUMENTATION "Enable documentation" ON)
+if(ENABLE_DOCUMENTATION)
+ add_subdirectory(doc)
+endif()
#
# Installation