summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-02-28 13:10:02 +0000
committerKitware Robot <kwrobot@kitware.com>2023-02-28 08:10:16 -0500
commit60c50d4e5105afae93208203de9a296ed18ebeaa (patch)
tree01b22f07e59fe805bf547665071f24c6b1addbe3 /CMakeLists.txt
parent0fd241b80c2adee2dbd622524af64b0d86a74cf2 (diff)
parent2fc3b0f47604caad605cd4672b159c98355883e0 (diff)
downloadcmake-60c50d4e5105afae93208203de9a296ed18ebeaa.tar.gz
Merge topic 'test-no-dart'
2fc3b0f476 Tests: Drop use of legacy "Dart" module Acked-by: Kitware Robot <kwrobot@kitware.com> Tested-by: buildbot <buildbot@kitware.com> Merge-request: !8257
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce113110a6..6322aa6022 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -241,10 +241,6 @@ macro(CMAKE_SETUP_TESTING)
configure_file(Tests/.NoDartCoverage Tests/.NoDartCoverage)
configure_file(Tests/.NoDartCoverage Modules/.NoDartCoverage)
configure_file(CTestCustom.cmake.in CTestCustom.cmake @ONLY)
- if(BUILD_TESTING AND DART_ROOT)
- configure_file(CMakeLogo.gif Testing/HTML/TestingResults/Icons/Logo.gif COPYONLY)
- endif()
- mark_as_advanced(DART_ROOT)
endmacro()
@@ -361,9 +357,7 @@ endif()
#-----------------------------------------------------------------------
include(Source/CMakeVersion.cmake)
-# Include the standard Dart testing module
-enable_testing()
-include(${CMAKE_ROOT}/Modules/Dart.cmake)
+include(CTest)
# Set up test-time configuration.
set_directory_properties(PROPERTIES