summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-03-06 14:24:38 +0000
committerKitware Robot <kwrobot@kitware.com>2020-03-06 09:24:45 -0500
commitb7d43ea0da43aa8fcb7cbe846469d555d2877f36 (patch)
tree6a17478a5bfdc9f96b84d8542c1baef6b085abc7 /CMakeLists.txt
parenta1ccbab5a883d6f9d89827b63ffc039f9e4b296b (diff)
parent917db8163d645eb1dfe61ee9d74eb373fe0b4b2f (diff)
downloadcmake-b7d43ea0da43aa8fcb7cbe846469d555d2877f36.tar.gz
Merge topic 'cmstd-IBM-i' into release-3.17
917db8163d cmstd: Remove -isystem option for IBM i (OS400) Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !4430
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7d139b390..18b8d7d6e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -367,7 +367,7 @@ macro (CMAKE_BUILD_UTILITIES)
# Setup third-party libraries.
# Everything in the tree should be able to include files from the
# Utilities directory.
- if (CMAKE_SYSTEM_NAME STREQUAL "AIX" AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ if ((CMAKE_SYSTEM_NAME STREQUAL "AIX" OR CMAKE_SYSTEM_NAME STREQUAL "OS400") AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
# using -isystem option generate error "template with C linkage"
include_directories("${CMake_SOURCE_DIR}/Utilities/std")
else()