summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-24 17:15:12 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-24 17:15:12 -0400
commit29f7f3a9ea28f063b84520421f1ef58698b26d84 (patch)
tree8f3172a8d627bc15f3b675c7ac5f63cf08745b61 /configure.in
parentd1ca23a3f9980875dff593da718353c7b9151083 (diff)
downloadcmake-29f7f3a9ea28f063b84520421f1ef58698b26d84.tar.gz
auto detect lang:std:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d4030ba4fb..6a4099a2be 100644
--- a/configure.in
+++ b/configure.in
@@ -102,7 +102,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
#include <iostream>
!
- if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_ANSI_CFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_STREAM_HEADERS)
@@ -118,7 +118,7 @@ if test $ac_cv_prog_gxx = no; then
#include <list>
void foo() { std::list<int> l; }
!
- if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_ANSI_CFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_STD_NAMESPACE)
@@ -133,7 +133,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
void foo() { for(int i;;); for(int i;;); }
!
- if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_ANSI_CFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_FOR_SCOPE)