summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d4030ba4fb..6a4099a2be 100644
--- a/configure.in
+++ b/configure.in
@@ -102,7 +102,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
#include <iostream>
!
- if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_ANSI_CFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_STREAM_HEADERS)
@@ -118,7 +118,7 @@ if test $ac_cv_prog_gxx = no; then
#include <list>
void foo() { std::list<int> l; }
!
- if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_ANSI_CFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_STD_NAMESPACE)
@@ -133,7 +133,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
void foo() { for(int i;;); for(int i;;); }
!
- if test -z "`${CXX} $CMAKE_TEMPLATE_FLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CMAKE_ANSI_CFLAGS $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_FOR_SCOPE)