summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2019-12-22 21:17:37 +0200
committerAdrian Thurston <thurston@colm.net>2019-12-22 21:17:37 +0200
commitcdaa1ab24a06ccbf71987b1516a96028a9c61b67 (patch)
treeae78c9b7dc60c69e6c7a0cf9d5e67dc446a78301 /configure.ac
parentca2fc51203d0539934dcf49d2d9c7592cebb96d7 (diff)
downloadcolm-cdaa1ab24a06ccbf71987b1516a96028a9c61b67.tar.gz
with-colm build: need to make tar dir, added a check for the colm bin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 88d8493c..5e1b9ee4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -334,10 +334,15 @@ SED_SUBST="$SED_SUBST -e 's|@CRACK_BIN@|${CRACK_BIN}|g'"
AC_SUBST(CRACK_BIN)
-dnl Generic dependency specification.
+dnl Skip bootstrap and build using an existing version of colm. Allows us to
+dnl break colm without breaking the build of colm.
AC_ARG_WITH(colm,
- [AC_HELP_STRING([--with-colm], [colm install to build bootstrap programs])],
- [EXTERNAL_COLM="$withval"],
+ [AC_HELP_STRING([--with-colm], [prefix of colm install to build with, instead of bootstrapping])],
+ [
+ EXTERNAL_COLM="$withval"
+ AC_CHECK_FILES(["$EXTERNAL_COLM/bin/colm"], [],
+ [AC_ERROR(["could not find $EXTERNAL_COLM/bin/colm"])])
+ ],
[]
)