summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 88d8493c..5e1b9ee4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -334,10 +334,15 @@ SED_SUBST="$SED_SUBST -e 's|@CRACK_BIN@|${CRACK_BIN}|g'"
AC_SUBST(CRACK_BIN)
-dnl Generic dependency specification.
+dnl Skip bootstrap and build using an existing version of colm. Allows us to
+dnl break colm without breaking the build of colm.
AC_ARG_WITH(colm,
- [AC_HELP_STRING([--with-colm], [colm install to build bootstrap programs])],
- [EXTERNAL_COLM="$withval"],
+ [AC_HELP_STRING([--with-colm], [prefix of colm install to build with, instead of bootstrapping])],
+ [
+ EXTERNAL_COLM="$withval"
+ AC_CHECK_FILES(["$EXTERNAL_COLM/bin/colm"], [],
+ [AC_ERROR(["could not find $EXTERNAL_COLM/bin/colm"])])
+ ],
[]
)