summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Dennis <rdennis@gmail.com>2014-02-24 21:52:09 -0500
committerRob Dennis <rdennis@gmail.com>2014-02-24 21:52:09 -0500
commit88c4e3667adc0b3df129427ef528faa4394da1de (patch)
tree1f2b2cc2042c33f2ce7f6859d81859c4ea93db91 /setup.py
parentff623954dc54ea369bb4dab3e22373fc65651830 (diff)
downloadconfigobj-git-88c4e3667adc0b3df129427ef528faa4394da1de.tar.gz
fixes #26 - added check for python versions < 2.6 with error message
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 79ee914..190cab3 100644
--- a/setup.py
+++ b/setup.py
@@ -10,9 +10,14 @@
# This software is licensed under the terms of the BSD license.
# http://opensource.org/licenses/BSD-3-Clause
-
+import sys
from distutils.core import setup
+if sys.version_info < (2, 6):
+ print('for python versions < 2.6 use configobj '
+ 'version 4.7.2')
+ sys.exit(1)
+
# TODO - #20 - refactor the way we do versions
VERSION = '5.0.1'
NAME = 'configobj'