summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 79ee914..190cab3 100644
--- a/setup.py
+++ b/setup.py
@@ -10,9 +10,14 @@
# This software is licensed under the terms of the BSD license.
# http://opensource.org/licenses/BSD-3-Clause
-
+import sys
from distutils.core import setup
+if sys.version_info < (2, 6):
+ print('for python versions < 2.6 use configobj '
+ 'version 4.7.2')
+ sys.exit(1)
+
# TODO - #20 - refactor the way we do versions
VERSION = '5.0.1'
NAME = 'configobj'