summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRob Dennis <rdennis@gmail.com>2014-02-19 21:44:24 -0500
committerRob Dennis <rdennis@gmail.com>2014-02-19 21:44:24 -0500
commitf461e506d74bddb48af27923fe3cf6ae40544a64 (patch)
treecc47133250bf601345f523b94b9c0f29ffb2f616 /setup.py
parent23c1d703555bf8d411023a4eed6305d2b78ac977 (diff)
downloadconfigobj-git-f461e506d74bddb48af27923fe3cf6ae40544a64.tar.gz
removing the checked-in six.py in favor of listing it as a dependency
this necessitated moving around the version specification due to the issues that come when you do imports from setup.py. Opened #20 and #21
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3e466e2..f47a890 100644
--- a/setup.py
+++ b/setup.py
@@ -12,11 +12,11 @@
# http://opensource.org/licenses/BSD-3-Clause
from distutils.core import setup
-from configobj import __version__ as VERSION
+# TODO - #20 - refactor the way we do versions
+VERSION = '5.0.1'
NAME = 'configobj'
-
-MODULES = 'configobj', 'validate', 'six'
+MODULES = 'configobj', 'validate'
DESCRIPTION = 'Config file reading, writing and validation.'
@@ -75,6 +75,7 @@ KEYWORDS = "config, ini, dictionary, application, admin, sysadmin, configuration
setup(name=NAME,
version=VERSION,
+ install_requires=['six==1.5.2'],
description=DESCRIPTION,
long_description=LONG_DESCRIPTION,
author=AUTHOR,