summaryrefslogtreecommitdiff
path: root/zephyr/test/drivers/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/drivers/common/CMakeLists.txt')
-rw-r--r--zephyr/test/drivers/common/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/zephyr/test/drivers/common/CMakeLists.txt b/zephyr/test/drivers/common/CMakeLists.txt
new file mode 100644
index 0000000000..854294ab11
--- /dev/null
+++ b/zephyr/test/drivers/common/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Common sources
+target_sources(app PRIVATE
+ src/main.c
+ src/test_mocks.c
+ src/test_rules.c
+ src/utils.c
+ src/stubs.c
+)
+target_include_directories(app PRIVATE
+ ${CMAKE_CURRENT_SOURCE_DIR}/include
+ ${PLATFORM_EC}/driver/ppc/
+ ${PLATFORM_EC}/zephyr/shim/src/led_driver
+)