summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2022-03-17 14:28:34 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2022-03-29 12:47:59 +0000
commitdd8638e1319272887aef1a4b5aaa39d2fb9914be (patch)
treede8289eb26f3f79cf263eb8c2779db91ba59fee0 /CMakeLists.txt
parent8d86453b8279f8fc1126f50f441f1a8141e7925b (diff)
downloaddbus-dd8638e1319272887aef1a4b5aaa39d2fb9914be.tar.gz
cmake: temporary disable fatal warnings related to new opensuse builds
This is necessary for these CI builds to be successful. Signed-off-by: Ralf Habacker <ralf.habacker@freenet.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 890618dc..99f102c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -332,8 +332,11 @@ else()
pointer-sign
)
set(WARNINGS_DISABLED
+ error=inline
error=overloaded-virtual
error=missing-field-initializers
+ error=null-dereference
+ error=strict-aliasing
error=unused-parameter
unused-parameter
)