summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 890618dc..99f102c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -332,8 +332,11 @@ else()
pointer-sign
)
set(WARNINGS_DISABLED
+ error=inline
error=overloaded-virtual
error=missing-field-initializers
+ error=null-dereference
+ error=strict-aliasing
error=unused-parameter
unused-parameter
)