summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-11-15 15:48:26 +0000
committerSimon McVittie <smcv@collabora.com>2019-01-21 15:20:04 +0000
commit24a1f3406ab709928baabbc19007880cfbca0d7c (patch)
tree8bf115b17ba86cd3ee8aa08277ff9a759bad0a4c /test/Makefile.am
parentb7f11c17d15fabebf216445be58afd0e321fc1b9 (diff)
downloaddbus-24a1f3406ab709928baabbc19007880cfbca0d7c.tar.gz
test: Split slow parts of the former test-dbus into their own executables
This makes it easier for a developer to run just the fast parts while debugging some issue reproduced by the faster tests. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index eecfec85..58e72559 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -83,6 +83,9 @@ uninstallable_test_programs += \
test-bus \
test-bus-dispatch \
test-bus-dispatch-sha1 \
+ test-hash \
+ test-marshal-recursive \
+ test-message-internals \
test-misc-internals \
$(NULL)
@@ -197,6 +200,15 @@ test_bus_dispatch_sha1_LDADD = \
libdbus-testutils.la \
$(NULL)
+test_hash_SOURCES = internals/hash.c
+test_hash_LDADD = libdbus-testutils.la
+
+test_marshal_recursive_SOURCES = internals/marshal-recursive.c
+test_marshal_recursive_LDADD = libdbus-testutils.la
+
+test_message_internals_SOURCES = internals/message-internals.c
+test_message_internals_LDADD = libdbus-testutils.la
+
test_misc_internals_SOURCES = internals/misc-internals.c
test_misc_internals_LDADD = libdbus-testutils.la