summaryrefslogtreecommitdiff
path: root/DevIL/CMakeLists.txt
diff options
context:
space:
mode:
authorDenton Woods <denton.woods@gmail.com>2017-01-29 15:08:59 -0600
committerGitHub <noreply@github.com>2017-01-29 15:08:59 -0600
commit2508df57950039b1434d25d5c83efa6af4cc2ee5 (patch)
treee52c3e6da8e47f836731b92bf5d6dd10ed0e8833 /DevIL/CMakeLists.txt
parentc7911f4048b418b9c008dde3ffeb01b783bd260d (diff)
parent3d5ad51edb4eff44790dd9c30c5370bdabc0d588 (diff)
downloaddevil-2508df57950039b1434d25d5c83efa6af4cc2ee5.tar.gz
Merge pull request #51 from abma/master
fix linux compile + add travis-ci support
Diffstat (limited to 'DevIL/CMakeLists.txt')
-rw-r--r--DevIL/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/DevIL/CMakeLists.txt b/DevIL/CMakeLists.txt
index a26f8eac..e342f93d 100644
--- a/DevIL/CMakeLists.txt
+++ b/DevIL/CMakeLists.txt
@@ -7,4 +7,9 @@ set (CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules")
add_subdirectory(src-IL)
add_subdirectory(src-ILU)
add_subdirectory(src-ILUT)
+option(IL_TESTS "build DevIL tests" ON)
+if (IL_TESTS)
+ ENABLE_TESTING()
+ Add_Subdirectory(test)
+endif()