summaryrefslogtreecommitdiff
path: root/DevIL/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'DevIL/CMakeLists.txt')
-rw-r--r--DevIL/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/DevIL/CMakeLists.txt b/DevIL/CMakeLists.txt
index a26f8eac..e342f93d 100644
--- a/DevIL/CMakeLists.txt
+++ b/DevIL/CMakeLists.txt
@@ -7,4 +7,9 @@ set (CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules")
add_subdirectory(src-IL)
add_subdirectory(src-ILU)
add_subdirectory(src-ILUT)
+option(IL_TESTS "build DevIL tests" ON)
+if (IL_TESTS)
+ ENABLE_TESTING()
+ Add_Subdirectory(test)
+endif()