summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authordoursse <doursse>2005-09-29 10:15:47 +0000
committerdoursse <doursse@7cbeb6ba-43b4-40fd-8cce-4c39aea84d33>2005-09-29 10:15:47 +0000
commit7b6bf008cfee88eee29b9a022c0936f286a08b32 (patch)
tree029b59b214e9bc67b397ec8e20e1ba3ea8c39731 /doc/Makefile.am
parenteefcf05d0a889c5d99f373e678a3a5417e24644a (diff)
downloadeet-7b6bf008cfee88eee29b9a022c0936f286a08b32.tar.gz
add clean rules and add files for distribution
SVN revision: 17062
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am28
1 files changed, 21 insertions, 7 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 844a02f..b76ecc1 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -8,7 +8,7 @@ all-local: doc-build.stamp
# rule to remove all old created files
doc-prepare.stamp:
- @if test x"html" != x ; then \
+ @if test -d html ; then \
rm -rf html/ latex/ man/ xml/; \
fi
@@ -17,18 +17,32 @@ doc-build.stamp: doc-prepare.stamp
@doxygen
@cp img/*.png html/
+# rules to clean
+clean-local:
+ @rm -rf html/ latex/ man/ xml/
+
+distclean-local: clean
+ rm -f Makefile.in
+
# rule to install the documentation in $(docdir)
install-data-local:
- @if ! test -d "$(DESTDIR)$(datadir)/$(PACKAGE)"; then \
- mkdir "$(DESTDIR)$(datadir)/$(PACKAGE)"; \
+ @if ! test -d $(DESTDIR)$(datadir)/$(PACKAGE); then \
+ mkdir $(DESTDIR)$(datadir)/$(PACKAGE); \
fi
- @if ! test -d "$(DESTDIR)$(docdir)"; then \
- mkdir "$(DESTDIR)$(docdir)"; \
+ @if ! test -d $(DESTDIR)$(docdir); then \
+ mkdir $(DESTDIR)$(docdir); \
fi
- @cp -pr html/ man/ latex/ xml/ "$(DESTDIR)$(docdir)"
+ @cp -pr html/ man/ latex/ xml/ $(DESTDIR)$(docdir)
# rule to uninstall the documentation
uninstall-local:
- rm -rf $(docdir)
+ rm -rf $(DESTDIR)$(docdir)
+
+
+MAINTAINERCLEANFILES = Makefile.in eet.c
+
+DISTCLEANFILES = Makefile.in eet.c
+
+EXTRA_DIST = Doxyfile eet.css foot.html head.html img/
endif