summaryrefslogtreecommitdiff
path: root/legacy/emotion/src/bin/Makefile.am
diff options
context:
space:
mode:
authorVincent Torri <vincent.torri@gmail.com>2010-01-04 18:45:40 +0000
committerVincent Torri <vincent.torri@gmail.com>2010-01-04 18:45:40 +0000
commit2a1b159536aa73770a769ee32c06f47515a86b69 (patch)
tree42874be2b49b0294ef8751c61fedb7419f0ea308 /legacy/emotion/src/bin/Makefile.am
parenta4b0afb1e4b467a1ce7c605095b7da5cb01db275 (diff)
downloadefl-2a1b159536aa73770a769ee32c06f47515a86b69.tar.gz
* enable static build of modules
* clean up autotools * remove some warnings issues: * vlc backend can not be built on my computer(API change in libvlc, it seems) * when i build xine *and* gstreamer as static, i get a multiple defined of __eina_module_init and __eina_module_shutdown SVN revision: 44884
Diffstat (limited to 'legacy/emotion/src/bin/Makefile.am')
-rw-r--r--legacy/emotion/src/bin/Makefile.am17
1 files changed, 7 insertions, 10 deletions
diff --git a/legacy/emotion/src/bin/Makefile.am b/legacy/emotion/src/bin/Makefile.am
index a90d5987b3..bc016d3ff0 100644
--- a/legacy/emotion/src/bin/Makefile.am
+++ b/legacy/emotion/src/bin/Makefile.am
@@ -7,16 +7,13 @@ AM_CPPFLAGS = \
-DPACKAGE_BIN_DIR=\"$(bindir)\" \
-DPACKAGE_LIB_DIR=\"$(libdir)\" \
-DPACKAGE_DATA_DIR=\"$(datadir)/$(PACKAGE)\" \
-@EVAS_CFLAGS@ \
-@ECORE_CFLAGS@ \
-@EDJE_CFLAGS@
+@EMOTION_CPPFLAGS@ \
+@EMOTION_BIN_CFLAGS@ \
+@ECORE_X_CFLAGS@ \
+@ECORE_FB_CFLAGS@
-bin_PROGRAMS = \
-emotion_test
+bin_PROGRAMS = emotion_test
-emotion_test_SOURCES = \
-emotion_test_main.c
+emotion_test_SOURCES = emotion_test_main.c
-emotion_test_LDADD = \
-@EVAS_LIBS@ @ECORE_LIBS@ @EDJE_LIBS@ \
-$(top_builddir)/src/lib/libemotion.la
+emotion_test_LDADD = @ECORE_X_CFLAGS@ @ECORE_FB_CFLAGS@ @EMOTION_BIN_LIBS@ $(top_builddir)/src/lib/libemotion.la