summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2014-10-30 19:36:25 -0400
committerOlivier CrĂȘte <olivier.crete@collabora.com>2015-02-25 16:43:45 -0500
commit45861c192761b7059a6ffd4b6daea2ebcdd82642 (patch)
tree1cd12d6486d920a24b7fa668cc95e08abcfe6605 /configure.ac
parentadb4765979f627dfce44590b243cd74af086da9a (diff)
downloadfarstream-45861c192761b7059a6ffd4b6daea2ebcdd82642.tar.gz
Enable building static FsPlugins
This required change FS_INIT_PLUGIN() macro. It's now taking name and type argumenet. This is a slight API break, but there never existed any external plugins. Also, already built plugins should not be affected since the symbol remains the same. Note also that plugin are no longer unloadable, it was already not well supported. Instead of adding loads of if, we simply register the module types as static (just like GStreamer does). To register static plugin, you can declare it's registration function using FS_PLUGIN_STATIC_DECLARE(name), and then in your code call the function using FS_PLUGIN_STATIC_REGISTER(name). https://bugs.freedesktop.org/show_bug.cgi?id=89287
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ffb9db6c..7973e053 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,7 +337,7 @@ AC_SUBST(FS_LIB_LDFLAGS)
dnl this really should only contain flags, not libs - they get added before
dnl whatevertarget_LIBS and -L flags here affect the rest of the linking
-FS_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*fs_init_plugin\$\$' $FS_ALL_LDFLAGS"
+FS_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*fs_.*plugin.*' $FS_ALL_LDFLAGS"
AC_SUBST(FS_PLUGIN_LDFLAGS)
dnl this really should only contain flags, not libs - they get added before