summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorДилян Палаузов <dilyan.palauzov@aegee.org>2022-10-20 17:05:04 +0200
committerTom de Vries <tdevries@suse.de>2022-10-21 08:51:16 +0200
commit36ba985145ffa8e2078033fc1f1cf22851707a8e (patch)
treea7acb21ab75f25babdae8c795fd0e40770ba69dd /configure.ac
parentf56d48b2471c388401174029324e1f4c4b84fcdb (diff)
downloadgcc-36ba985145ffa8e2078033fc1f1cf22851707a8e.tar.gz
Don't build readline/libreadline.a, when --with-system-readline is supplied
https://sourceware.org/bugzilla/show_bug.cgi?id=18632 The bundled libreadline is always built, even if the system is ./configure'd --with-system-readline and the build libreadline.a is not used. Proposed patch: Fix ./configure.ac not to proceed readline/, when --with-system- readline is provided * configure.ac: Don't configure readline if --with-system-readline is used. * configure: Re-generate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2cff32e300e..1df410bba1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,12 @@ if test x$with_system_zlib = xyes ; then
noconfigdirs="$noconfigdirs zlib"
fi
+# Don't compile the bundled readline/libreadline.a if --with-system-readline
+# is provided.
+if test x$with_system_readline = xyes ; then
+ noconfigdirs="$noconfigdirs readline"
+fi
+
# some tools are so dependent upon X11 that if we're not building with X,
# it's not even worth trying to configure, much less build, that tool.