summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorDoug Evans <dje@google.com>2010-04-23 18:07:26 +0000
committerDoug Evans <dje@google.com>2010-04-23 18:07:26 +0000
commit6bbc19c7d525e49ce12c21ad5a5f85d4d720a573 (patch)
treeb3510f4a23a6d87de42697978449232bcf9ac42d /gdb/configure.ac
parent2ea3662be0ca74cf18a79cf8792af955a3f866ed (diff)
downloadgdb-6bbc19c7d525e49ce12c21ad5a5f85d4d720a573.tar.gz
* configure.ac (CONFIG_SRCS): Add py-auto-load.o even if not using
python. * configure: Regenerate. * main.c: #include "python/python.h". (captured_main): Defer loading auto-loaded scripts until after local_gdbinit has been sourced. * python/py-auto-load.c (gdbpy_global_auto_load): New global. (load_auto_scripts_for_objfile): New function. (auto_load_new_objfile): Call it. * python/python.h (gdbpy_global_auto_load): Declare. (load_auto_scripts_for_objfile): Declare.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 434c5b4da9e..4704a538b69 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -701,9 +701,10 @@ if test "${have_libpython}" = yes; then
fi
else
# Even if Python support is not compiled in, we need to have these files
- # included in order to recognize the GDB command "python".
- CONFIG_OBS="$CONFIG_OBS python.o py-value.o py-prettyprint.o"
- CONFIG_SRCS="$CONFIG_SRCS python/python.c python/py-value.c python/py-prettyprint.c"
+ # included.
+ CONFIG_OBS="$CONFIG_OBS python.o py-value.o py-prettyprint.o py-auto-load.o"
+ CONFIG_SRCS="$CONFIG_SRCS python/python.c python/py-value.c \
+ python/py-prettyprint.c python/py-auto-load.c"
fi
AC_SUBST(PYTHON_CFLAGS)