summaryrefslogtreecommitdiff
path: root/docs/tutorial/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-05-06 21:55:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-05-06 21:55:41 +0000
commit629a0e14248812e55e9245bad9e01d9bc6bd2d0a (patch)
tree4805be6ed3f1fab22e7f536861e8e4f896e63b2c /docs/tutorial/Makefile.am
parent2e58122c793a66f6241ff4bfe74e8966a043eeb3 (diff)
downloadgdk-pixbuf-629a0e14248812e55e9245bad9e01d9bc6bd2d0a.tar.gz
Patch from James Henstridge to update to automake-1.7 (#109542)
Tue May 6 16:50:52 2003 Owen Taylor <otaylor@redhat.com> Patch from James Henstridge to update to automake-1.7 (#109542) * autogen.sh: update to call newer tools. * configure.in: various updates, to use M4 macros to put variables that change each release at the top. Use AC_HELP_STRING to format help strings. Use AC_CONFIG_COMMANDS to generate gdkconfig.h. * Makefile.am: require Automake 1.7. Remove gdk-2.0.pc and gtk+-2.0.pc on uninstall. Pass --enable-gtk-doc to configure during distcheck. * docs/reference/*/Makefile.am: simplify to use the gtk-doc.make makefile fragment. * */Makefile.am: don't use STRIP_BEGIN/STRIP_END. Use BUILT_SOURCES where appropriate. Build generated files in builddir rather than srcdir. Fix uninstall and distclean targets to satisfy distcheck. === * gdk/*/Makefile.am: Remove the hacks to get gdkenumtypes.h built first, since we are now using BUILT_SOURCES. * gdk/Makefile.am: Remove an outdated comment about gdk_headers. * demos/gtk-demo/Makefile.am: Fix srcdir != buildd problem with geninclude.pl. * configure.in: Update versions to 2.3.0.
Diffstat (limited to 'docs/tutorial/Makefile.am')
-rw-r--r--docs/tutorial/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/docs/tutorial/Makefile.am b/docs/tutorial/Makefile.am
index 91bd749a1..d5b46a1b5 100644
--- a/docs/tutorial/Makefile.am
+++ b/docs/tutorial/Makefile.am
@@ -35,16 +35,20 @@ EXTRA_DIST = \
images/tictactoe.png
if HAVE_DOCBOOK
-html:
- (cd $(srcdir); \
- db2html gtk-tut.sgml; \
- test -d html && rm -r html; \
- mv gtk-tut html; \
- mkdir html/images; \
- cp images/*.png html/images)
+html:
+ if test -w $(srcdir); then \
+ (cd $(srcdir); \
+ db2html gtk-tut.sgml; \
+ test -d html && rm -r html; \
+ mv gtk-tut html; \
+ mkdir html/images; \
+ cp images/*.png html/images); \
+ fi
pdf:
- (cd $(srcdir); db2pdf gtk-tut.sgml)
+ if test -w $(srcdir); then \
+ (cd $(srcdir); db2pdf gtk-tut.sgml); \
+ fi
dist-hook: html
cp -Rp $(srcdir)/html $(distdir)