summaryrefslogtreecommitdiff
path: root/docs/tutorial/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/tutorial/Makefile.am')
-rw-r--r--docs/tutorial/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/docs/tutorial/Makefile.am b/docs/tutorial/Makefile.am
index 91bd749a1..d5b46a1b5 100644
--- a/docs/tutorial/Makefile.am
+++ b/docs/tutorial/Makefile.am
@@ -35,16 +35,20 @@ EXTRA_DIST = \
images/tictactoe.png
if HAVE_DOCBOOK
-html:
- (cd $(srcdir); \
- db2html gtk-tut.sgml; \
- test -d html && rm -r html; \
- mv gtk-tut html; \
- mkdir html/images; \
- cp images/*.png html/images)
+html:
+ if test -w $(srcdir); then \
+ (cd $(srcdir); \
+ db2html gtk-tut.sgml; \
+ test -d html && rm -r html; \
+ mv gtk-tut html; \
+ mkdir html/images; \
+ cp images/*.png html/images); \
+ fi
pdf:
- (cd $(srcdir); db2pdf gtk-tut.sgml)
+ if test -w $(srcdir); then \
+ (cd $(srcdir); db2pdf gtk-tut.sgml); \
+ fi
dist-hook: html
cp -Rp $(srcdir)/html $(distdir)