summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gmail.com>2022-08-09 15:28:35 +0000
committerEmmanuele Bassi <ebassi@gmail.com>2022-08-09 15:28:35 +0000
commitf49eb1b4bdcafe94c5aa33fdcee754613931588a (patch)
treecfbda716ca59952ec711cc861c73842aa2dc6bb1 /meson.build
parent2d88dac38974bdc1e7a09142c101867db4ce69df (diff)
parent89fce0c2a1887b139b8a1bfbeb30c3d243c56f52 (diff)
downloadgdk-pixbuf-f49eb1b4bdcafe94c5aa33fdcee754613931588a.tar.gz
Merge branch 'disable_relocation_on_static' into 'master'
Disable relocation when built as a static libary on Windows See merge request GNOME/gdk-pixbuf!136
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ed82464e4..6b123847f 100644
--- a/meson.build
+++ b/meson.build
@@ -382,7 +382,7 @@ endif
# Determine whether we enable application bundle relocation support, and we use
# this always on Windows
if host_system == 'windows'
- relocatable = true
+ relocatable = (get_option('default_library') != 'static')
else
relocatable = get_option('relocatable')
endif
@@ -447,7 +447,7 @@ summary('MediaLib', use_medialib, section: 'Build')
summary('Introspection', build_gir, section: 'Build')
summary('Documentation', build_docs, section: 'Build')
summary('Manual pages', get_option('man'), section: 'Build')
-summary('Relocatable', get_option('relocatable'), section: 'Build')
+summary('Relocatable', relocatable, section: 'Build')
summary('Build tests', get_option('tests'), section: 'Build')
summary('Installed tests', get_option('installed_tests'), section: 'Build')