summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuergen Gehring <juergen.gehring@bmw.de>2017-04-07 01:32:39 -0700
committerJuergen Gehring <juergen.gehring@bmw.de>2017-04-07 01:32:39 -0700
commit44103948d4b052603c0b361448ecb4ef7d954f79 (patch)
treef7c95861a4128e0f1cb058eff73ff2911a37f468 /CMakeLists.txt
parentfad59c73675aea115d0c292b5743de2591bdf6b3 (diff)
downloadgenivi-common-api-dbus-runtime-44103948d4b052603c0b361448ecb4ef7d954f79.tar.gz
CommonAPI-D-Bus 3.1.11.13.1.11.1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 350a1ed..b40aa56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -177,8 +177,12 @@ include_directories(
${DBus_INCLUDE_DIRS}
)
-if ("${USE_INSTALLED_DBUS}" STREQUAL "OFF")
- set (DBus_LIBRARIES dbus-1)
+if ("${USE_INSTALLED_DBUS}" STREQUAL "ON")
+ link_directories(
+ ${DBus_LIBRARY_DIRS}
+ )
+else()
+ set (DBus_LIBRARIES dbus-1)
link_directories(
${DBus_INCLUDE_DIRS}/dbus/.libs
)