summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 350a1ed..b40aa56 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -177,8 +177,12 @@ include_directories(
${DBus_INCLUDE_DIRS}
)
-if ("${USE_INSTALLED_DBUS}" STREQUAL "OFF")
- set (DBus_LIBRARIES dbus-1)
+if ("${USE_INSTALLED_DBUS}" STREQUAL "ON")
+ link_directories(
+ ${DBus_LIBRARY_DIRS}
+ )
+else()
+ set (DBus_LIBRARIES dbus-1)
link_directories(
${DBus_INCLUDE_DIRS}/dbus/.libs
)