summaryrefslogtreecommitdiff
path: root/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
diff options
context:
space:
mode:
authorEugen Friedrich <efriedrich@de.adit-jv.com>2023-01-20 11:21:24 +0100
committerEugen Friedrich <efriedrich@de.adit-jv.com>2023-01-20 11:21:24 +0100
commit90a904b0ad57b5a4149a366307b54249bc109854 (patch)
tree8376783a71f5618876bdc6686add3a1ddde25585 /ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
parent40596515569210b603caff702568681659c05fec (diff)
parent4c7d574af5cfba7a06c6d5575ee699ee8381fab8 (diff)
downloadwayland-ivi-extension-90a904b0ad57b5a4149a366307b54249bc109854.tar.gz
Merge remote-tracking branch 'upstream/pull/141'
* upstream/pull/141 CMakeLists: update libweston to version 8 Remove unused function decodeEscapesequences Remove unused function importSceneFromTXTHelper Add missing include of endian.h Fix crash in controller_screenshot_notify Reviewed-by: Eugen Friedrich <efriedrich@de.adit-jv.com> Reviewed-by: Harsha M M <harsha.manjulamallikarjun@in.bosch.com> Tested-by: Doan Ngoc Au <au.doanngoc@vn.bosch.com>
Diffstat (limited to 'ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt')
-rw-r--r--ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt b/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
index 847c9a1..d3bb616 100644
--- a/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
+++ b/ivi-layermanagement-examples/simple-weston-client/CMakeLists.txt
@@ -22,14 +22,14 @@ project (simple-weston-client)
find_package(PkgConfig)
pkg_check_modules(WAYLAND_CLIENT wayland-client REQUIRED)
pkg_check_modules(WAYLAND_CURSOR wayland-cursor REQUIRED)
-pkg_check_modules(LIBWESTON_PROTOCOLS libweston-7-protocols QUIET)
+pkg_check_modules(LIBWESTON_PROTOCOLS libweston-8-protocols QUIET)
if(${LIBWESTON_PROTOCOLS_FOUND})
#check for DLT
pkg_check_modules(DLT automotive-dlt QUIET)
#import the pkgdatadir from libweston-protocols pkgconfig file
- execute_process(COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=pkgdatadir libweston-7-protocols
+ execute_process(COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=pkgdatadir libweston-8-protocols
OUTPUT_VARIABLE WestonProtocols_PKGDATADIR)
string(REGEX REPLACE "[\r\n]" "" WestonProtocols_PKGDATADIR "${WestonProtocols_PKGDATADIR}")
SET(LIBWESTON_PROTOCOLS_PKGDATADIR ${WestonProtocols_PKGDATADIR})